Stark schwankende Stromanzeige

  • Guten Tag,


    ich hatte mich bereits im Forum registriert – leider kam keine Bestätigungs-email und so kann ich mich dort nicht einloggen.


    Frage zum Batterie-Monitor: Warum schwankt die Anzeige zwischen 1 und 5 A extrem, wenn der Motor läuft?


    Bei höheren Amperezahlen ist die Anzeige rel. konstant, nur im niederen Bereich schwankt sie ganz wild.


    Ohne Motor ist die Anzeige konstant, und zeigt an je nachdem was eingeschalten ist die Ampere an.


    Mit freundlichen Grüßen

  • Hallo,


    dieses Verhalten kann zwei Ursachen haben.


    1. Die Strom in Ihrem Bordnetz schwankt bei niedrigen Strömen tatsächlich sehr stark und genau das wird durch die Anzeige dokumentiert. Das wird häufig durch bei geringer Last schwingende Spannungsregler in der Lichtmaschine verursacht.


    2. Die Lichtmaschine des Fahrzeugs erzeugt prinzipbedingt Wechselstrom, der zunächst gleichgerichtet und dann der Batterie zugeleitet wird. Der Gleichrichter innerhalb der Lichtmaschine macht daraus zwar einen Strom, der nur in einer Richtung fließt, aber das tut er nicht völlig gleichmäßig (also nicht so, wie ein gleichmässiger Batteriestrom das täte), sondern der Form der Lichtmaschinenspannung entsprechend. Da es sich bei der Limaspannung wie gesagt um gleichgerichteten Wechselstrom handelt, bleibt die Spannungsform trotz der Gleichrichtung gleich und besitzt Täler und Berge.



    Links Wechselspannung, rechts gleichgerichtete Wechselspannung, auch genannt "wellige Gleichspannung". Die vormals negative Halbwelle ist nach oben geklappt.


    Man sieht an der Spannungsform, dass es Zeiten hoher Spannung, aber auch Zeiten niedriger Spannung gibt.


    Der Analog-Digitalwandler im Batteriemonitor macht nun folgendes: Er tastet über einen kurzen Zeitraum die Spannung an der Batterie (bzw. zur Strommessung am Shunt) ab, wandelt den Messwert in digitales Format und bringt ihn zur Anzeige. Wenn die Abtastung zu dem Zeitpunkt des Wellenmaximums stattfindet, wird eine hohe Spannung (bzw. ein hoher Strom) angezeigt, so, wie er ja auch gemessen wurde. Fällt dagegen die Abtastung in den Zeitraum des Wellentals, wird nur ein deutlich geringerer Wert angezeigt, da dann ja auch nur ein sehr geringer Wert gemessen wird.


    Bei höherer Drehzahl als einen sehr niedrigen Motorleerlauf sollte sich dieses Phänomen jedoch verwischen, weil dann die Impulspausen der Spannung kürzer werden als die Messzeit des AD-Wandlers. Sollte das Problem also auch bei höherer Motordrehzahl gleichermaßen vorliegen, wird man davon ausgehen müssen, dass der Strom im Effektivwert wirklich so stark schwankt, wie ihn der Batterie-Monitor anzeigt.


    Ich hoffe, ich konnte Ihnen weiterhelfen.


    Viele Grüße!


    Thomas Rücker


    PS: Ihr eMail-Hoster hat leider Probleme mit unserem eMail-Server. Meine eMails werden jeweils mit einer eMail Ihres eMail-Hosters beantwortet, dass diese nicht zustellbar seien. Offenbar werden sie jedoch trotzdem korrekt zugestellt. Ich habe die Fehlermeldungen an meinen Systemadministrator weiter geleitet, falls die Ursache hierfür auf unserer Seite zu suchen ist. Das kann eventuell die Ursache dafür sein, dass Ihnen die Bestätigungsmail meines Forums nicht zugegangen ist.

  • Hallo,


    zunächst einmal sollte man feststellen, ob der Regler der Lichtmaschine wirklich schwingt, oder ob das aufgezeigte Problem mit der Probentastung des Analag/Digital-Wandlers hier die Ursache ist. Im ersten Fall ist die Art der Abhilfe klar: Am Lichtmaschinen-Regler, bzw. an der Masseverbindung der Lichtmaschine nachbessern.


    Im zweiten Fall wird's schwieriger, weil man entweder die Dauer der Probentastung verlängern muss, oder man müsste das Messsignal selbst "verlangsamen", also tiefpassfiltern. Mit dem entsprechende Wissen um die innere Schaltung des A/D-Wandlers und der Messwertanzeige könnte man dort eventuell ansetzen. Dieses Wissen ist leider nicht vorhanden. Daher kann man diesen Weg nicht ohne weiteres beschreiten.


    Man müsste also das Messsignal selbst tiefpassfiltern, was wegen des Shunts als Messwertgeber leider nicht ganz einfach ist, denn die dort erzeugte Messspannung ist mit nur wenigen Millivolt zu gering und eignet sich daher nicht dafür, einer Tiefpassfilterung über RC-Glieder direkt zugeführt zu werden. Daher wäre eine vorherige Verstärkung über eine zusätzliche Verstärkerschaltung mit anschließendem Tiefpassfilter nötig.


    Fazit: Gehen tut sowas, aber der Aufwand ist leider recht hoch.


    Grüße, Tom

  • Was wäre, wenn man dem Shunt einfach einen hochwertigen Kondensator geeigneter Größe (groß genug, um kurzzeitige Spannungsschwankungen abzupuffern, aber klein genug, um den Meßwert nicht gleich über Sekunden zu verfälschen) parallellschaltet?
    Er würde über den Shunt selbst jeweils auf dessen momentanen Spannungsabfall geladen bzw. entladen, würde aber diesen Vorgang durch seine Stromaufnahme deutlich verzögern - also die sehr schnellen Schwankungen des Spannungsabfalls glätten. Der Meßwert wäre damit je nach Kapazität leicht zeitverzögert und würde sich dem Effektivwert nähern.
    Grüße, Martin

    Mit einem Draht klappt es nicht, und ab zwei kann man verwechseln. (Unbekannt)

  • So würde man das normalerweise machen. Aber das funktioniert hier leider nicht, denn der Shunt besitzt nur einen Widerstand von winzigen 0,37mOhm, also 0,00037Ohm. Daran fallen bei einem Strom von 1A genau 370µV ab. Also den Kondensator möchte ich sehen, mit dessen Hilfe sich 370µV bei einer Systemimpedanz von 0,37mOhm stabilisieren lassen. Ich hab's jetzt nicht berechnet, aber unter 1.000f (aber bitte ganze Farad, keine millionstel (µ)) wird sich da wohl nichts abspielen... :thumbsup:


    Selbst wenn der Eingangswiderstand der Anzeigeelektronik sehr hoch wäre und man z.B. einen Widerstand von 100k zwischen Shunt und Kondensator schalten könnte, um diesen brachialen Kurzschluss, den der Shunt selbst darstellt, vom Kondensator fernzuhalten, wird man immer noch größte Schwierigkeiten haben, so geringe Spannungen mit Kondensatoren zu stabilisieren. Und selbst wenn das bei einem sehr großen und gleichzeitig sehr leckstromarmen Kondensator tatsächlich funktionieren sollte, müsste wenigstens das Messwerk neu abgeglichen werden, damit die Anzeige wieder stimmt. Wie man's auch dreht und wendet: Diese Methode kann man hier leider vergessen.


    Im Grunde wäre also der einzig gangbare Weg der, dass man die Schaltung am Eingang des A/D-Wandlers durch "reengineering" analysiert und dann dort an geeigneter Stelle ansetzt.


    Grüße, Tom

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!